Metamask Aave loan repayment - Error getting txParams

I’ve been struggling for two days and nights now trying to repay a loan I got from AAVE app. The loan is for $10,000 BUSD and 5.84 wETH was used for collateral. So I go to [https://app.aave.com/->Your borrows->Repay->Collateral->MAX Debt amount to repay, but all I get is the error message: “There was some error. Please try changing the parameters or copy the error”. When I copy and paste the error says: “Error getting txParams”. And that’s it. I’ve tried changing the Max slippage rate, as well as the Debt Amount to Repay, but unless I go to as low as $100 BUSD repayment, all I get is the same error message. There’s $1,000 USD worth of ETH in my Metamask wallet to cover for gas fees. Please help. Thank you.

Hi @archmaster , I am having the same issue! Have you managed to figure out the solution?

Hi @tray1975us. No. I never did, and was never able to contact anyone who could help me with this. As a result of that I got automatically liquidated on the last market dip, and the $6,000 usd worth of ETH that should have remained in my wallet are now worth only $900 usd. This is unacceptable, but the worst part of it is that there’s no one to put the blame on and no one will be responsible. DO NOT USE AAVE, IS THE WORST PIECE OF SHIT SOFTWARE I HAVE EVER INTERACTED WITH. As a web developer, I’ll make sure all of my site’s followers are aware of this.

@archmaster OMG… I am scared now. I am trapped with know way to get my funds out of there. I am trying to join forums and all I get so far is scammers trying to get me to give up my private keys. This sucks!

Damn - that sucks… I’ve never had any issue repaying a loan personally, so I wouldn’t be able to offer any help.

Were there any error messages thrown from the browser console?

Perhaps we can bring attention to this issue for future users or get the devs to implement more helpful error messages.

I think the aave interface repo ist a better place to report such issues GitHub - aave/interface: An open source interface for the decentralized liquidity protocol Aave so someone will see it.

“Error getting tx Params” can have multiple reasons. It essentially means that paraswap(which is used for the underlying swap) wasn’t able to build the TXN.
If a repayment rate was shown before that means that for some reason the api wasn’t able to build a TXN for the route if found. Might be better to ask paraswap or look in the console network tab to see if there’s some more helpful error on the api response.

Reasons I saw in the past:

  • buggy api
  • api down/rate limited
  • one of the amms used in the route blocking your address for whatever reason

Anyhow without any actual error message it’s hard to say anything as it’s just guessing. If your not comfortable with sharing your public wallet address you could try reaching out via intercom on aave.com which will probably reach a developer.


One known issue with collateral repay right now is on repay with stETH which is quite special.

Thanks sakulstra for your help! I just logged a question on the GitHub forum you suggested. Here is the actual error message I keep getting…(Any other thoughts?)