Problems All Day w/ Aave Polygon V3

I tried borrowing earlier in the day. It failed 3 times on the polygon network when I checked the explorer…so I cant borrow. So I decided to wait a while…

Now. I bought some Polygon and cant supply the platform from my Ledger Live. Error message was saying “there was an error please trying changing the parameters” several times when trying. Then it changed to the “Supplying MATIC” button just perpetually swirling/loading…no prompt for the next step is given in Ledger Live to proceed to the next step. It’s just stuck. Any suggestions? This has not happened before.

1 Like

Could you elaborate on this, what is the failure?

Second, are you connecting LedgerLive through WalletConnect? If so, it’s possible that the wallet connection was lost and you just need to disconnect/reconnect to submit transactions. You may also want to check the browser console to see if there is an error thrown when you are submitting the transaction.

Once we have more info on the errors and wallet setup we can check to see if there’s an issue that can be reproduced :)

1 Like

I dont get it. The borrow for $3k usdc in polygon v3 finally worked this morning. “Success” on the polygon explorer and funds went to my Ledger Live. Now, Im getting failed transactions again to borrow $1k…and it’s still charging gas (10 cents but still a charge). This has been a smooth process for about six months…now Im presented with this problem.

This is the txn: 0xb9166669d5fe471f395090c0cd3c8408cef9d10b801450ac12b12efa2c62454f

Link to failed transaction on polygon explorer: Polygon Transaction Hash (Txhash) Details | PolygonScan

It’s saying " Warning! Error encountered during contract execution [out of gas"

It cant be talking about my wallet because I have over 500 matic in it to cover gas costs. Is this talking about the contract gas? How do I deal with this?

How do I increase the gas I want to pay via Ledger so that the transaction goes thru? Please dont leave me hanging…I think this is the solution if you can help me. Thanks.

I believe Ive figured it out. I see how to manually up the gas fee in Ledger and the transactions are going thru easier.

Well…it’s halfway working. Still having trouble supplying Polygon. It’s a gotdamned shame we have to come to a forum to try to get some answers on how to navigate this bullshit. Crypto will never go mainstream with this level of complexity and risk…this coming from a dude who’s been invested since May 2017. There is very little to no help whatsoever in the Ledger app, Aave platform, on the internet, on message boards…nothing. There should be in-app/in-protocol real time guides and recommendations as we go. Aint no way in hell should I be wrestling with this bullshit for 2-3 days now. This is bullshit.

Hi, sorry for the delay and any inconvenience this caused,

Based on your message it seems you figured out this specific error can be fixed by manually increasing the gas limit of the txn, this is not ideal though and should be prevented in the Aave UI. I investigated, found the cause, and implemented a fix here. Once this is reviewed and merged (hopefully tomorrow or Monday) this issue should be resolved.

In the future, the Aave discord and open source interface repo are preferred channels to report issues like this since they’re more actively monitored by developers.


Okay thanks. Im new so didnt know where to post this. When I started having these ongoing frustrating issues, I found myself here looking for help. Im still dealing with issues right at this very moment. I thought I had it figured out for the most part. I cant supply matic/polygon to the platform. Im upping the gas fee…that was beginning to help. I decided to try refreshing the aave app when I received random error messages…that was beginning to help. Now Im experiencing problems with the Ledger Live/device. It either just says “Sign Transaction” with the swirling thing forever…never prompting me to verify and review. Or it does prompt me to verify and review and I “accept”…and then NOTHING happens lol. The whole transaction disappears. There is no tab that pops up on the bottom right corner of Ledger Live like normally for me to view the transaction details. It just poofs…no error message no nothing…and Im left sitting thinking Im going crazy. “Hey…didnt I just try to process a transaction or was I dreaming??” Ive tried to supply at least 20 times today. This is mentally exhausting. Im jumpin back and forth from the “updated” Live 2.57 to the older 2.54 version like a circus animal…hoping one of those will finally work for me. This is a pain. Im taking a break until later tonight and hopefully the system will be ready to do its job for me. I cant spend all day wrestling with these apps and Ledger device…